External Database connectivity issues in Composer 2
Incident Report for AppGyver
Resolved
Connectivity issues have returned to normal levels.
Posted Dec 23, 2015 - 10:14 UTC
Investigating
We are investigating
Posted Dec 22, 2015 - 11:49 UTC